Scheduled for March 27, 2026 at 1:09 PM – 1:24 PM
Affects
App
Under maintenance from 1:09 PM to 1:24 PM
Completed
March 27, 2026 at 1:24 PMCompleted
March 27, 2026 at 1:24 PMMaintenance has completed successfully.
In progress
March 27, 2026 at 1:20 PMIn progress
March 27, 2026 at 1:20 PMMaintenance is now in progress.
Planned
March 27, 2026 at 1:09 PMPlanned
March 27, 2026 at 1:09 PMWe are planning for a scheduled maintenance during that time.