Scheduled for April 11, 2025 at 10:20 AM – 10:54 AM
Affects
App
Under maintenance from 10:20 AM to 10:54 AM
Completed
April 11, 2025 at 10:54 AMCompleted
April 11, 2025 at 10:54 AMMaintenance has completed successfully.
In progress
April 11, 2025 at 10:36 AMIn progress
April 11, 2025 at 10:36 AMMaintenance is now in progress.
Planned
April 11, 2025 at 10:20 AMPlanned
April 11, 2025 at 10:20 AMWe are planning for a scheduled maintenance during that time.